
Isis Cricket Club Statistics – Google Sheets 

Scorecard Entry – Volunteer User Guide 
 

1 
 

1. Contents 
2. Before you start ..................................................................................................................... 2 

3. Create a File ........................................................................................................................... 2 

4. Set up the batch ..................................................................................................................... 3 

5. Entering Scorecard Data ........................................................................................................ 4 

5.1 Confirm the match displays correctly (top-left) ............................................................ 4 

5.2 Enter Match Header details .......................................................................................... 4 

5.3 Registering New or Guest players ................................................................................. 5 

5.4 Enter Batting Details ..................................................................................................... 5 

5.5 Enter Batting Extras ....................................................................................................... 6 

5.6 Enter Bowling Details .................................................................................................... 6 

5.7 Enter Bowling Extras ..................................................................................................... 7 

5.8 Enter Fielding Details..................................................................................................... 7 

5.9 Final Checks ................................................................................................................... 7 

5.10 Result / Scorecard Errors Affecting a “Balanced” outcome ........................................... 8 

5.11 Close the Workflow ....................................................................................................... 8 

6. What if I see “  Not Balanced”? ......................................................................................... 9 

7. Hints and Tips ...................................................................................................................... 10 

8. Worked Examples ................................................................................................................ 12 

8.1 Scorecard completed – and balanced (existing players only) ...................................... 12 

8.2 Scorecard completed – and balanced (includes new players) ..................................... 13 

8.3 Scorecard completed – and NOT balanced ................................................................. 14 

 

  



Isis Cricket Club Statistics – Google Sheets 

Scorecard Entry – Volunteer User Guide 
 

2 
 

2. Before you start 
This guide explains how to complete a template worksheet to submit scorecards to the club’s 

statistics data store.  No prior knowledge of Google Sheets is assumed and there are some hints 

and tips about getting set up at the end of this document.  Read those first - follow the “Set Up” 

and “Create Drive Folders” instructions, which need only be done when you first use the system. 

 

To set up the operational environment, the club administrator should have shared two files and 

one folder with you.  Open Drive, and in in the left-hand menu click on “Shared with me”.  You 

should see the folder and files per the screen shot below. 

 

 

3. Create a File 
1. When you’re ready to start, right click on PUB_IsisCC_Scorecard_Template and choose 

Make a copy 

2. Once the notification confirms the file is created you can click on Open file location, or 

alternatively click on My Drive in the left-hand menu 

3. You should see a file “Copy of PUB_IsisCC_SCorecard_Template” in the My Drive folder.  

Double-click on that file and it will open in a new browser window on the Home tab as 

per the screenshot below. 

4. On this screen click File and then select Move and 01_WIP as the destination folder.  

When you have finished creating the scorecard you will move the file again, but until 

that time you will always find your file there. 
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4. Set up the batch 
The home tab provides both a simple batch header, and below that is a green admin dashboard.  

The abridged user instruction to the right is a summarised view of this guide.  The green admin 

dashboard remains blank until the scoresheet is ready for submission. 

 

As you can see top-left, when the file is first created you must first allow data connection to 

bring data into the new file (when you do, data is passed from the IsisCC_Lookups file that was 

shared with you).  This then enables the template’s functionality to work. 

1. Simply move the cursor to cell H2 and in the pop-up click the green “Allow Access” 

button.  After a short pause, data connection will be established, and you should see the 

connection status switch to “  Data Connected – Lookups Active”. 

2. Then In cell E13:H13, enter your initials, and you will see the Batch Date/Time field 

populate automatically. 

3. Use the drop-down in E14:H14to select the match to score.n  Only unplayed matches 

will appear in the dropdown. 

4. Right click in the filename field E16:H16 and press Ctrl+C. 

5. Then click in the Sheets file name at the top left of the screen, press Ctrl+A to highlight 

the field contents and press Shift+CTRL+V to past the filename.  After you press Enter, 

the bowser window reflects this new permanent file name. 

6. The last thing to do in setup is to freeze the Batch Date/Time on the Home screen.  To 

do this click in cell E15:H15, Ctrl+A and then Ctrl+C to copy the cell contents, and then 

press Ctrl+Shift+V.  This stores that value into the cell and locks it.  It means that you can 

return as often as you wish without the timestamp refreshing. 
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Before you leave the Home tab  just notice the Scorecard_Entry tab at the bottom of the screen.  

You only use this tab for your part in the workflow.  There are hidden tabs that serve the 

administration side of the process and can remain hidden.  Now, click the Scorecard_Entry tab 

and we’ll proceed to enter the scorecard data.  

5. Entering Scorecard Data 

5.1 Confirm the match displays correctly (top-left) 
1. The match you selected on the home screen pulls through to cell A2. 

2. Opponent (venue), format and overs are populated automatically). 

5.2 Enter Match Header details 
A few additional match header fields must now be entered: 

1. Look at the scorebook and update the number of overs played in cell F2 if it is different 

to the value shown.  In bad light or bad weather conditions the captains may have 

agreed to a reduce the number of overs. 

2. Use the dropdown in cell F2 to select whether “Isis” or “Opponent” batted first.  This is 

used in determining formatting of the result.  If the scorebook does not make this clear 

use these guidelines: 

a. If the result is that Isis won by runs, Isis batted first. 

b. If the result is that Isis lost by runs, the opponent batted first. 

c. If the result is that Isis won by wickets, the opponent batted first. 

d. If Isis lost by wickets, Isis batted first 

3. After setting who batted first, then set the status of the match in K2, where you select 

from “Completed” or “Abandoned” (Cancelled matches will be managed by the 

administrator)  

4. If the match was “Cancelled” or “Abandoned”, then please fill cell K2 with one of those 

values from the dropdown. 

5. The scorecard is self-reconciling after you have entered some control totals – when you 

enter player batting, bowling and fielding total runs and wickets will be  calculated.  But 

we enter some control totals so that the sheet can warn if there is a difference with 

those control totals (if there is a difference, the result will not appear in cell G6 and the 

home page will show “  Not Balanced".  The control totals arte there to help uou.  So 

now… 

6. From the scorebook, enter the Isis runs in cell B5 and wickets in cell B6 

7. Then enter the opponent runs in cell D5 and wickets in cell D6 in the same way 

8. These controls are designed to help you and to ensure the Isis statistics remain accurate 

and of high quality.  The validation is done in hidden cells that are not revealed to avoid 

accidental editing. 
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As the volunteer submitting the scorebook data, all you are concerned with after completing the 

scorecard is achieving a “Balanced” status.  The Home tab can show error conditions for the 

database administrator to take action on, but those actions are not your immediate concern.  

When the scorecard shows Balanced the file is ready for submission. 

 

I’ll show a couple of examples of completed scorecards in various states after explaining the 

data entry process, for reference purposes. 

5.3 Registering New or Guest players 
In the scorecard, you’ll enter the Isis batting order, so scan the list of names in the 

scorebook and determine if any new members or guests have played that will be unknown 

to the system.  If there aren’t any, you can skip to the “Enter Batting” section. 

 

 
 

• If there are new or guest players in the team, they should be entered in rows 35 to 40 of 

the scorecard file you just created.  You can simply fill in the Surname, First Name and 

initials in rows 35 to 40. 

▪ Enter initials without a period (“.”). 

▪ As an example, for Keith Whiter enter Surname=Whiter, First Name=Keith, 

Initials=K) and the spreadsheet will format the DisplayName column as K. Whiter. 

▪ The GS01-GS06 identifiers are an internal control and should not be changed. 

▪ Once the names are entered here, these new names should appear in the dropdown 

selection for the batting order.  When all new members/guests have been added, 

that’s the next step. 

 

5.4 Enter Batting Details 

You are now ready to start entering the match details.  The first thing to do is populate the Isis 

batting card.  The dropdowns in B12 through B24 enable you to allocate each player in the 

scorebook to a position in the batting order.  The dropdown selection is based on “active” 
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players (players who have played in the past three seasons) and once the team is in the batting 

card, other dropdowns (bowling, fielding) will be limited to just those players. 

 

1. Now, enter the players in batting order (positions 1–11) using the dropdown.  See hints 

and tips for quick selection from dropdown. 

2. If the player batted, tick the 'Batted' box in column C. 

3. Enter the runs they scored in column D, including a big fat 0 for ducks.  No need to enter 

a score if a player did not bat. 

4. Check the scorebook tally if completed and count how many sixes (if any) the batsman 

hit and enter that count in column E (sixes are counted to determine the “Big Hit” award 

at the end of the season). 

5. Finally select the type of dismissal in the HowOut column (F) from the dropdown.  If the 

person was not out in a retirement game select Not Out, if they reached a landmark 

score and walked out, then choose Retired.  Do not enter HowOut if Batted is not ticked 

(leave it blank). 

 

• There are 13 rows available as very occasionally captains agree to a larger team size 

than 11 (say, on tour).  Similarly, we may play with only, say 10 men due to 

unavailability.  Just ensure there are no blank slots in the middle of the order.  If there 

were not 11 men, leave the last rows blank. 

5.5 Enter Batting Extras 
Then enter Byes, Leg-byes, Wides, No Balls and Fielding Penalties credited to the Isis 

score in cells D25 through D29 respectively. 

5.6 Enter Bowling Details 
Now, in the same way as you selected the batting order, you will select the bowling order. 

1. Select bowlers from the dropdown in cells I12 to I24.  Only the team names you entered 

in batting are included. 

2. Enter how many Overs each bowler bowled in column J.  Use the traditional cricket 

format (e.g. 6.5 means six overs and five balls). 

3. Enter how many Maiden overs the bowler achieved in column K. 

4. Enter the total runs the bowler conceded in column L – we do not track wides and no 

balls against bowlers, just the total. 

5. Finally, enter how many Wickets the bowler took (if any) in column M. 

 

Important: 

▪ If Runs or Wickets are entered, Overs must also be entered. 

▪ Do not leave blank columns for any named bowler.  If a bowler was named in the 

scorecard, but they did not get to bowl, do not enter their name in the order please. 
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5.7 Enter Bowling Extras 
You will have noticed that as you have been completing the batting and bowling analysis, the 

total runs and wickets are being recalculated in row 30 (batting) and row 28 (bowling).  At the 

point that you complete those, if the scorecard balances to the control totals you entered 

earlier, the result will appear in cell G6. 

1. Now, enter Byes, Leg Byes and Penalties that are credited to the Opposition score in 

cells L25, L26 and L27 respectively. 

2. And then notice if the result appears in G6.  If it doesn’t, we’ll go back to the reasons 

why once you have completed entering fielding events.   

5.8 Enter Fielding Details 
Finally, enter any fielding events that are listed in the scorebook, in the Isis Fielding section. 

1. In the same way as you selected names for batting and bowling, now fill cells O12 to 

O24 with the names of anybody who took a catch, made a run-out or took a stumping. 

2. Fill columns P, Q and R with the number of each type of fielding event for that player. 

3. Just like before, no names with blanks between names, and no names without stats 

please. 

 

The combined results of the bowling and fielding section are reflected in the runs and wickets 

analysis in row 28.  A run-out (not credited to a bowler) will increase the total wickets in that 

calculated total.  It’s the last piece of information that will signify if you have a balanced 

scorecard or not.  If the result appears in G6 you are in good shape.  If it doesn’t, we now need 

to determine why. 

5.9 Final Checks 

1. Go to the Home tab. 

2. The spreadsheet’s internal validation gives a summary status in cells D31 to D33.   If the 

spreadsheet is ready for import you will see: 

• Worksheet Status = “  READY FOR SUBMISSION” (cell D31), 

• Balanced status = ”  Balanced” (cell D32), and  

• Open Issues = “   No blocking issues” (cell D33) 

3. If that is the case, then you can proceed to submit the file for the Administrator to 

import the data.  Your primary concern is achieving a balanced scorecard.  If you see 

that, you are in the right place. 

4. However, if there are so called “Blocking Issues”, they will show in columns D and E 

starting at row 33 on the Home tab.  Potential issues and associated actions are listed in 

the Appendix.  Any issues not shown or are not listed in the Appendix are the domain of 

the Administrator to resolve. 
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5.10 Result / Scorecard Errors Affecting a “Balanced” outcome 
If the result does not appear it may be the case that you have entered scorecard data 

exactly as presented and due to the quality of scoring, the player data and extras do not 

match the recorded result which you used to set the control totals.  In this situation you 

have a choice of what to do to “Balance” the scorecard: 

1. The calculated runs and wickets are shown in cells D30 for batting and L38 for 

bowling.  You can accept the calculated scores as the official result, by entering 

those runs and wickets in the control fields B5 and B6 (for the Isis batting innings) 

and D5/D6 (for the Isis bowling innings). 

2. Or you can change the data entered in the batting, bowling and fielding blocks to 

bring the calculated totals in line with the control totals. 

3. Or if the difference is negligible, you could just ‘fiddle’ extras.   

4. However, you resolve this, ensure the match outcome does not change or that 

player scores stay close to what is recorded in the scorebook – do not arbitrarily 

penalize one playes statistics ove another’s. 

 

For small differences, adding or removing extras to bring the runs total to balance is the 

least path of resistance.  But do try and keep the scores as accurate as possible and 

ensure that the result reflects the agreed outcome. 

 

5.11 Close the Workflow 

When all actions have been taken, go to Home and check the status.  If it shows   

Balanced it is time to submit the file for the Administrator’s attention.  To do this: 

1. Click File → Move 

2. Click on “All locations” and click My Drive and navigate to ” → ”2 – Submissions” → “1 – 

Inbox – New Files”. 

3. Then press the highlighted MOVE control. 

This will move the file to the right place for the administrator to open the file and import 

the data you have supplied to the main database.  You can then close the file and exit 

Google Drive.  Thank you for your work. 
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6. What if I see “  Not Balanced”? 
Potential issues and associated actions are as follows (any errors not shown here are for the 

database admin to resolve) : 

1. Issue: MatchID not present.  Action: Ensure a match is selected in Home Screen!E14 

2. Issue: Result Status not yet selected.  Action: Cell K2 in must contain “Completed”, 

“Abandoned” or “Cancelled” 

3. Issue: Reconciliation Failure.  Action: The scorebook is wrong (there’s a difference 

between calculated scores and the control totals.  If you trust the player stats, update 

the control totals to match calculated totals.  Otherwise adjust the player data to adjust 

the calculated totals.  

4. Issue: At least two batsmen must have batted.  Action: At least two batsmen rows must 

have “Batted” ticked.  If the match was Abandoned it is fine though.. 

5. Issue: No negative numeric values.  Action:  All numbers on this sheet must be a 

positive integer (with the exception of Overs, which may be entered as “n.n”) 

6. Issue: “No batting stats without batsmen”, or “No bowling stats without bowler” or 

“No fielding events without fielder”.  Action: Values exist in a cell where a 

corresponding player has not been selected.  Either select the player or delete the value. 

7. Issue: Resolve gaps in batting order.  Action: Fill the blank row so there are no blank 

rows in the order.  Blank rows after the last data row are fine.  

8. Issue: If a player did not bat, Runs, Sixes and HowOut must all be blank.  Action: A 

value for runs, Sixes or HowOut exists, but the corresponding Batted entry is not ticked. 

9. Issue: A player must be Out or Not Out if they batted.  Action: A batsman row has 

Batted ticked, but there is not an “How Out” value – select from the dropdown. 

10. Issue: A bowler has Overs blank, but has runs and or wickets.  Action: A bowler in the 

bowling block shows no Overs value but shows runs or wickets.  Enter the number of 

overs that that bowler bowled. 
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7. Hints and Tips 
 

Set Up an Account 

• In order that you can participate in completing and submitting fixtures you must 

have a personal Google account.  This is free to anybody.  Once you set up an 

account send details of your Gmail to cricketisiscc@gmail.com. 

• The administrator of the club account (normally the club secretary) will share the 

relevant files with you..  When shared, you will receive an email from “IsisCC 

Cricket (via Google Drive)” with an email body saying “IsisCC Cricket 

(cricketisiscc@gmail.com) has invited you to contribute to the following …”. 

• The shared folder or file should be available in your personal Google Drive 

(application).  To access this tool, in your Gmail account click ⋮⋮⋮ (top right) and 

open the Drive application in Google Apps (top-right and near your avatar or 

initial.  A number of applications will be shown and you need to find “Drive”.  

 

Create Drive Folders 

• In Drive and in the left-hand menu click on My Drive 

• Click on + New and choose New Folder 

• Enter the folder name as IsisCC and click Create 

• Once the folder name appears in My Drive, double click that folder to open it 

• Again, click on +New, choose New Folder and create [your name] 

• Double-click that folder and create 2 folders 01_WIP and 02_Submitted 

• Note the path My Drive > Isiscc > [you name] is shown above the folder list and tells you 

exactly where you are in Drive. 
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Files and File Operations 

• A file exists in one place in Drive and has its own unique URL 

• A file or folder that you create exists in your personal account and is owned by you. 

• A file or folder that is shared with you exists in the account of the person who shared it. 

• When anything is shared, it is shared with a privilege allowing certain operations: 

1. Editor – open, read, edit, copy (not move or delete) 
2. Viewer – open, read, copy (not edit, move or delete) 

• To copy a file, right click and choose “Make a copy”. When you copy a file, a new file 

named “Copy Of …” is opened.  You own that file with editor privilege. 

  

Navigating Drive 

• When you open Drive you land on either Home or My Drive.  Set this to My Drive: 

1. Go to drive.google.com. 
2. At the top right, click Settings 
3. Under 'Start page', select Home or My Drive. 

• To navigate to a file or folder you own, click on My Drive first, and then double-click 

through your folder list to find what you are looking for. 

• To navigate to a file or folder shared with you: 

1. In Drive, select “Shared with me” from the drive menu. 
2. You can add a link to a shared file into you My Drive folder structures, by 

clicking Organise > Add Short Cut, and then choosing All locations, then My 
Drive and click through to the folder you want that link in. 

 
Copy and Paste in a Google Sheet 

• The most common operations you’’’ need when working with template files are: 

1. Copy (Ctrl+C) 
2. Paste Values Only (Ctrl+Shift+V) – data only, not formatting or formula 

• Note the difference between Paste Values and Paste 
3. Paste (Ctrl+V) – data, formatting and formula 

• Use caution with either of the paste operations.  If you paste into editable areas of the 
sheet, use Paste Values Only by default. 

 
Quick selection from Dropdowns 
The system has been set up to detect “active” people and opponents to stop dropdowns being 
too long.  But there are some ways to get to the thing you want quicker than  scrolling.  

▪ Start typing a keyword, such as “Wyatt” or “MCC”, and the dropdown list will offer 
potential matches. 

▪ If the match is to one record you can press TAB to select that one. 
▪ If more than one search candidate is shown you can just click on the one you want. 
▪ You will notice that dropdowns are alphabetical. 

 
 
 

https://drive.google.com/
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8. Worked Examples 

8.1 Scorecard completed – and balanced (existing players only) 
 

 

 

  

The Home tab admin dashboard shows that the 

scorecard is balanced, opening the export gate and 

filling the admin dashboard.  The batting, bowling and 

fielding statistics can be therefore be imported to the 

data store (line counts to import are shown). 
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8.2 Scorecard completed – and balanced (includes new players) 
 

  

Here, the blocked status is a note to the database 

admin, but as the scorecard is   Balanced it can be 

submitted.   

When the admin resolves the blocking condition 

(adds the new member) the export will be allowed 

and the line green admin dashboard will be filled. 
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8.3 Scorecard completed – and NOT balanced 

This last example shows an unbalanced scorecard; 

detailed reasons are in the Open Issues list. 

The second issue is the easiest to find first – Harry 

Stoneman can’t score -7 runs!  The bowling card 

calculated total explains the other issue – too many 

wickets.  Now, did Zach Wilkinson really take a run out? 

Did one of the bowlers take less wickets than indicated?  

Sometimes you’ll have to ask the team who played for 

the answer (if you were not there on the day. Here, Keith 

Whiter’s wicket count is overstated (doh!). 


